Показано с 1 по 3 из 3
  1. #1
    Пришел за помощью
    Регистрация
    02.03.2016
    Сообщений
    20
    Сказал(а) спасибо
    1
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Прервать печать ПФ

    Доброго времени суток!
    Код:
    Функция Печать(СсылкаНаДок, ТабДок) Экспорт		
    	Макет = ПолучитьМакет("Макет");
    	ДанныеДляЗаполнения = ПодготовитьДанные(СсылкаНаДок);
    	ЗаполнитьЗначенияСвойств(Макет.Параметры, ДанныеДляЗаполнения);
    	ТабДок.Вывести(Макет);
    	
    	Возврат ТабДок;		
    КонецФункции
    
    Функция ПодготовитьДанные(ДокОбъект) Экспорт		
    	СтруктураВозврата = Новый Структура("Имя");
    	Имя = "Something";
    	Если НЕ СтрДлина(Имя) > 0 Тогда
    		Предупреждение("Поле заполнено неверно!", , "Предупреждение!");
    		Возврат Ложь; // Неверное решение
    	КонецЕсли;	
    	Возврат СтруктураВозврата;		
    КонецФункции
    Пытаюсь прервать выполнение печати формы, если длина строки Имя меньше нуля. Не могу никак сообразить как это правильно сделать.
    Код:
    Возврат Ложь;
    Явно не то, что нужно.

  2. #2
    Модератор Аватар для Konor18
    Регистрация
    17.06.2020
    Сообщений
    95
    Сказал(а) спасибо
    24
    Поблагодарили 83 раз(а) в 34 сообщениях

    По умолчанию Re: Прервать печать ПФ

    Вы присваиваете переменной Имя значение "Something", далее проверяете длину переменной - длина всегда равна 9.

  3. #3
    Пришел за помощью
    Регистрация
    02.03.2016
    Сообщений
    20
    Сказал(а) спасибо
    1
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Re: Прервать печать ПФ

    Цитата Сообщение от Konor18 Посмотреть сообщение
    Вы присваиваете переменной Имя значение "Something", далее проверяете длину переменной - длина всегда равна 9.
    Это всего-лишь пример. Имя может быть и пустым.

Похожие темы

  1. Печать чеков ККМ через интернет (медленная печать)
    от evgeny2009 в разделе 1С - Предприятие 8.0, 8.1, 8.2, 8.3
    Ответов: 1
    Последнее сообщение: 03.11.2019, 19:06
  2. Печать УПД 8.2
    от NiVeR в разделе 1С - Предприятие 8.0, 8.1, 8.2, 8.3
    Ответов: 12
    Последнее сообщение: 29.01.2016, 14:17
  3. Печать ценников
    от SEREGATANK в разделе 1С Предприятие 8.1
    Ответов: 9
    Последнее сообщение: 02.07.2013, 00:12
  4. печать ценников
    от jawakharlal в разделе 1С - Предприятие 8.0, 8.1, 8.2, 8.3
    Ответов: 5
    Последнее сообщение: 10.01.2012, 02:16
  5. Медленная печать из 1С
    от Snejnaya в разделе 1С Предприятие 7.7
    Ответов: 6
    Последнее сообщение: 24.11.2010, 09:37

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •