Показано с 1 по 3 из 3
  1. #1
    Пришел за помощью
    Регистрация
    02.03.2016
    Сообщений
    20
    Сказал(а) спасибо
    1
    Поблагодарили 0 раз(а) в 0 сообщениях

    Question Создание внешней печатной формы

    Доброго времени суток!
    Пытаюсь создать внешнюю печатную форму используя макет, созданный в MS Word. Макет загружен как двоичные данные.

    Застрял на реализации самого вывода. Нужно просто вывести макет.

    Код:
    Функция Печать(Ссылка, ТабДокумент) Экспорт
        ДвоичныеДанныеМакета = ПолучитьМакет("МакетWord");
    
        ...
    
        Возврат ТабДокумент;
    КонецФункции

  2. #2
    Модератор Аватар для Konor18
    Регистрация
    17.06.2020
    Сообщений
    95
    Сказал(а) спасибо
    24
    Поблагодарили 83 раз(а) в 34 сообщениях

    По умолчанию Re: Создание внешней печатной формы

    Цитата Сообщение от Shouldercannon Посмотреть сообщение
    Доброго времени суток!
    Пытаюсь создать внешнюю печатную форму используя макет, созданный в MS Word. Макет загружен как двоичные данные.

    Застрял на реализации самого вывода. Нужно просто вывести макет.

    Код:
    Функция Печать(Ссылка, ТабДокумент) Экспорт
        ДвоичныеДанныеМакета = ПолучитьМакет("МакетWord");
    
        ...
    
        Возврат ТабДокумент;
    КонецФункции
    С вордом в 1С работа ведётся через COM соединение.

  3. #3
    Гордость форума
    Регистрация
    29.11.2013
    Адрес
    Берег Волги
    Сообщений
    1,392
    Сказал(а) спасибо
    195
    Поблагодарили 2,673 раз(а) в 964 сообщениях

    По умолчанию Re: Создание внешней печатной формы

    Цитата Сообщение от Shouldercannon Посмотреть сообщение
    Доброго времени суток!
    Пытаюсь создать внешнюю печатную форму используя макет, созданный в MS Word. Макет загружен как двоичные данные.

    Застрял на реализации самого вывода. Нужно просто вывести макет.

    Код:
    Функция Печать(Ссылка, ТабДокумент) Экспорт
        ДвоичныеДанныеМакета = ПолучитьМакет("МакетWord");
    
        ...
    
        Возврат ТабДокумент;
    КонецФункции
    [Только зарегистрированные пользователи могут видеть ссылки. ]
    [Только зарегистрированные пользователи могут видеть ссылки. ]

  4. 3 пользователя(ей) сказали cпасибо:

    arendaludena (19.11.2020), eoliya (02.12.2020), Shouldercannon (19.11.2020)

Похожие темы

  1. Печать внешней печатной формы УПД расходной накладной
    от Evangelina в разделе Конфигурирование, программирование 1С - Предприятие
    Ответов: 0
    Последнее сообщение: 21.11.2017, 15:10
  2. Помогите с внешней печатной формой
    от xdoker в разделе Конфигурирование, программирование 1С - Предприятие
    Ответов: 1
    Последнее сообщение: 29.09.2016, 17:33
  3. Помогите с внешней печатной формой
    от xdoker в разделе Конфигурирование, программирование 1С - Предприятие
    Ответов: 4
    Последнее сообщение: 22.09.2016, 14:04
  4. Не корректное заполнение внешней печатной формы
    от Александр8989 в разделе Установка и администрирование 1С - Предприятие
    Ответов: 9
    Последнее сообщение: 22.12.2015, 12:53
  5. Подмена значений во внешней печатной форме
    от sab1na в разделе 1С - Предприятие 8.0, 8.1, 8.2, 8.3
    Ответов: 1
    Последнее сообщение: 21.08.2012, 13:21

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •