Показано с 1 по 3 из 3
  1. #1
    Пришел за помощью
    Регистрация
    25.11.2016
    Сообщений
    36
    Сказал(а) спасибо
    1
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Расшифровка поля отчета другим отчетом обычные формы.

    Всем привет друзья. Сталкнулся с проблемой и не могу понять как сделать правильно.
    Задача:
    Сделать расшифровку поля другим отчетом, запрос такой же лишь Меняются параметры. ПОльзуясь гуглом и собирая код из разных частей сделал так

    Код:
    Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
    	
        Поле = ДанныеРасшифровки.Элементы[Расшифровка].ПолучитьПоля()[0];
        ТипРасшифровки = Поле.Поле;
        
        Если ТипРасшифровки = "Вагон" Тогда
        	
        	//ОчиститьСообщения();
        	
        	СтандартнаяОбработка = Ложь;
        	СтруктураРасшифровки = Новый Структура;
     
        	//Значения всех вышестоящих группировок		
        	ВывестиЗначениеГруппировки(Расшифровка, СтруктураРасшифровки);
        	
        	ФормаРасшифровки = ПолучитьФорму("ФормаРасшифровки");
        	ФормаРасшифровки.Открыть();
        	ФормаРасшифровки.СформироватьОтчетРасшифровки("СхемаКомпоновкиДанныхРасшифровки", 
    			СтруктураРасшифровки, 
    			"Расшифровка ячейки """ + ТипРасшифровки + """");
        	
        ИначеЕсли ТипРасшифровки = "Справочник" Тогда
        	
        	СтандартнаяОбработка = Ложь;
        	ОткрытьЗначение(Поле.Значение);
    
        КонецЕсли;	
        	
    КонецПроцедуры
    Вывод отчета

    Код:
    Процедура СформироватьОтчетРасшифровки(ИмяМакета, СтруктураРасшифровки, Заголовок = "Расшифровка ячейки") Экспорт  
    	
    	Результат = ЭлементыФормы.Результат;
    	Результат.Очистить();
    	
    	РасшифровкаСхемаКомпоновкиДанных = ПолучитьМакет(ИмяМакета);
    	
    	//Отборы
    	Для Каждого Значение ИЗ СтруктураРасшифровки Цикл
    		ДобавитьЗначениеОтбораРасшифровки(Значение.Ключ, Значение.Значение, , ВидСравненияКомпоновкиДанных.ВИерархии);
    	КонецЦикла;
    	
    	//Параметры
    	ДобавитьЗначениеПараметраРасшифровки("НачалоПериода",НачалоДня(НачалоПериода));
    	ДобавитьЗначениеПараметраРасшифровки("КонецПериода",КонецДня(КонецПериода));
    	
    	//Заголовок
    	ДобавитьЗначениеПараметраВыводаРасшифровки("Заголовок",Заголовок);
    	
    	//Получаем оформление из макета
    	МакетОформленияКомпоновкиДанных = ПолучитьМакет("МакетОформленияКомпоновкиДанныхПесок");
    	
    	РасшифровкаДанныеРасшифровки = Новый ДанныеРасшифровкиКомпоновкиДанных;
    	РасшифровкаНастройки = РасшифровкаСхемаКомпоновкиДанных.НастройкиПоУмолчанию;
    	
    	РасшифровкаКомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
    	РасшифровкаМакетКомпоновки = РасшифровкаКомпоновщикМакета.Выполнить(РасшифровкаСхемаКомпоновкиДанных, РасшифровкаНастройки, РасшифровкаДанныеРасшифровки, МакетОформленияКомпоновкиДанных);
    
    	РасшифровкаПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
    	РасшифровкаПроцессорКомпоновкиДанных.Инициализировать(РасшифровкаМакетКомпоновки, , РасшифровкаДанныеРасшифровки);
    
    	РасшифровкаПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    	РасшифровкаПроцессорВывода.УстановитьДокумент(Результат);
    	РасшифровкаПроцессорВывода.Вывести(РасшифровкаПроцессорКомпоновкиДанных);
    	
    	Результат.Защита = Истина;
    	
    КонецПроцедуры
    [ACRONYM]Ошибка [/ACRONYM]:

    Ошибка получения данных
    по причине:
    Ошибка создания набора данных "НаборДанных1"
    по причине:
    Ошибка при исполнении запроса набора данных
    по причине:
    {(15, 55)}: Не задано значение параметра "КонецПериода"
    ЖДНакладнаяВагоны.Ссылка.Д ата МЕЖДУ &НачалоПериода И <<?>>&КонецПериода
    Может кто делал подобное на обычных формах и может поделиться опытом?
    В расшифровку должны попасть 3 параметра, НАчало и конец даты + номер вагона по которому делается расшифровка

  2. #2
    Пришел за помощью
    Регистрация
    25.11.2016
    Сообщений
    36
    Сказал(а) спасибо
    1
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Re: Расшифровка поля отчета другим отчетом обычные формы.

    Вопрос закрыт. Параметры заполнять надо в "РасшифровкаНастройки"

  3. #3
    Пришел за помощью
    Регистрация
    25.11.2016
    Сообщений
    36
    Сказал(а) спасибо
    1
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Re: Расшифровка поля отчета другим отчетом обычные формы.

    Решено

Похожие темы

  1. Ответов: 1
    Последнее сообщение: 05.04.2017, 12:32
  2. Покажи свой сайт другим
    от S1mple в разделе Зацените-ка!
    Ответов: 17
    Последнее сообщение: 25.12.2016, 00:57
  3. Ответов: 5
    Последнее сообщение: 13.10.2011, 23:03
  4. Настройки структуры отчета, пользовательские поля
    от Charel в разделе 1С Предприятие 8.2
    Ответов: 1
    Последнее сообщение: 01.09.2011, 07:59

Метки этой темы

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •