Показано с 1 по 5 из 5
  1. #1
    Гость форума
    Регистрация
    25.07.2012
    Сообщений
    4
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Сложение ячеек

    в самописной базе есть справочник Контрагенты и документы Заказ, очень маленька база.
    Вроде все сделал, за исключением умножения кол-ва на цену за ед. для получения стоимости.
    Цена за ед. подтягивается ссылкой из Контрагентов, при прописании процедуры:

    Процедура КоличествоПриИзменении(Эл мент)
    Объект.Стоимость = Объект.Контрагент.ЦенаЕд * Объект.Количество
    КонецПроцедуры

    появляется ошибка:
    {Документ.Заказы.Форма.Форм аДокумента.Форма(4)}: Поле объекта не обнаружено (ЦенаЕд)
    Объект.Стоимость = Объект.Контрагент.ЦенаЕд * Объект.Количество

  2. #2
    Гость форума
    Регистрация
    25.07.2012
    Сообщений
    4
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Re: Сложение ячеек

    в самописной базе есть справочник Контрагенты и документы Заказ, очень маленька база.
    Вроде все сделал, за исключением умножения кол-ва на цену за ед. для получения стоимости.
    Цена за ед. подтягивается ссылкой из Контрагентов, при прописании процедуры:

    Процедура КоличествоПриИзменении(Эл мент)
    Объект.Стоимость = Объект.Контрагент.ЦенаЕд * Объект.Количество
    КонецПроцедуры

    появляется ошибка:
    {Документ.Заказы.Форма.Форм аДокумента.Форма(4)}: Поле объекта не обнаружено (ЦенаЕд)
    Объект.Стоимость = Объект.Контрагент.ЦенаЕд * Объект.Количество

  3. #3
    Старожил форума
    Регистрация
    18.07.2018
    Сообщений
    1,005
    Сказал(а) спасибо
    276
    Поблагодарили 3,032 раз(а) в 528 сообщениях

    По умолчанию Re: Сложение ячеек

    Цитата Сообщение от H0mRk Посмотреть сообщение
    в самописной базе есть справочник Контрагенты и документы Заказ, очень маленька база.
    Вроде все сделал, за исключением умножения кол-ва на цену за ед. для получения стоимости.
    Цена за ед. подтягивается ссылкой из Контрагентов, при прописании процедуры:

    Процедура КоличествоПриИзменении(Эл мент)
    Объект.Стоимость = Объект.Контрагент.ЦенаЕд * Объект.Количество
    КонецПроцедуры

    появляется ошибка:
    {Документ.Заказы.Форма.Форм аДокумента.Форма(4)}: Поле объекта не обнаружено (ЦенаЕд)
    Объект.Стоимость = Объект.Контрагент.ЦенаЕд * Объект.Количество
    Какая платформа и приложение? Если приложение управляемое, то где выполняется команда - на клиенте или на сервере?

  4. #4
    Гость форума
    Регистрация
    25.07.2012
    Сообщений
    4
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Re: Сложение ячеек

    1С:Предприятие 8.2, учебная версия (8.2.17.169)

  5. #5
    Гость форума
    Регистрация
    25.07.2012
    Сообщений
    4
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Re: Сложение ячеек

    на клиенте

Похожие темы

  1. Ответов: 0
    Последнее сообщение: 14.12.2010, 15:18

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •