Показано с 1 по 2 из 2
  1. #1
    Юзер
    Регистрация
    06.12.2018
    Сообщений
    7
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Автозаполнение колонки "Объект" в док-те Требование накладная

    Здравствуйте, подскажите пожалуйста как реализовать автозаполнение ячейки "Объект" табличной части документа из поля шапки "Объект" при создании новой строки?

    Пробовал так:
    Код:
    ////////////////////////////////////////////////////////////////////////////////
    // ОБРАБОТЧИКИ СОБЫТИЙ ТАБЛИЦЫ ФОРМЫ <Материалы>
    
    &НаСервере
    Функция МатериалыПриИзмененииНаСервере()
        Возврат Объект.Склад.ПодразделениеЗатрат;
    	Возврат Объект.Объект.Наименование;
    КонецФункции
    
    
    &НаКлиенте
    Процедура МатериалыПриИзменении(Элемент)
    	
    	Элемент.ТекущиеДанные.ПодразделениеЗатрат = МатериалыПриИзмененииНаСервере();
    	Элемент.ТекущиеДанные.Объект = МатериалыПриИзмененииНаСервере();
    	//УправлениеФормой(ЭтаФорма);
    	
    КонецПроцедуры
    ячейка «Объект», не заполняется,
    конфигурация сохраняется без ошибок
    в 1С при добавлении строки выскакивает предупреждение: "Поле объекта не обнаружено (Объект)"
    Куда копать? Помогите пожалуйста.
    Изображения Изображения

  2. #2
    Старожил форума
    Регистрация
    29.01.2010
    Сообщений
    1,410
    Сказал(а) спасибо
    28
    Поблагодарили 257 раз(а) в 241 сообщениях

    По умолчанию Re: Автозаполнение колонки "Объект" в док-те Требование накладная

    Цитата Сообщение от programmer007 Посмотреть сообщение
    Здравствуйте, подскажите пожалуйста как реализовать автозаполнение ячейки "Объект" табличной части документа из поля шапки "Объект" при создании новой строки?

    Пробовал так:
    Код:
    ////////////////////////////////////////////////////////////////////////////////
    // ОБРАБОТЧИКИ СОБЫТИЙ ТАБЛИЦЫ ФОРМЫ <Материалы>
    
    &НаСервере
    Функция МатериалыПриИзмененииНаСервере()
        Возврат Объект.Склад.ПодразделениеЗатрат;
    	Возврат Объект.Объект.Наименование;
    КонецФункции
    
    
    &НаКлиенте
    Процедура МатериалыПриИзменении(Элемент)
    	
    	Элемент.ТекущиеДанные.ПодразделениеЗатрат = МатериалыПриИзмененииНаСервере();
    	Элемент.ТекущиеДанные.Объект = МатериалыПриИзмененииНаСервере();
    	//УправлениеФормой(ЭтаФорма);
    	
    КонецПроцедуры
    ячейка «Объект», не заполняется,
    конфигурация сохраняется без ошибок
    в 1С при добавлении строки выскакивает предупреждение: "Поле объекта не обнаружено (Объект)"
    Куда копать? Помогите пожалуйста.
    (задумчиво) Функция МатериалыПриИзмененииНаСе рвере() всегда возвращает Объект.Склад.Подразделение Затрат; Второй "возврат" ей до фонаря.... поэтому не понятно что ты хочешь получить при втором вызове этой функции?

Похожие темы

  1. Запретить кнопку "Записать объект".
    от skillful в разделе 1С - Предприятие 8.0, 8.1, 8.2, 8.3
    Ответов: 7
    Последнее сообщение: 18.04.2019, 01:32
  2. Требование накладная заполнение колонки. 1С 8.3
    от programmer007 в разделе Конфигурирование, программирование 1С - Предприятие
    Ответов: 11
    Последнее сообщение: 25.12.2018, 11:07
  3. 1С УТ11 / как убрать обязательное поле "Проект" в объекте "Сделка с клиентом"?
    от d0ppe1ganger в разделе Установка и администрирование 1С - Предприятие
    Ответов: 5
    Последнее сообщение: 16.04.2014, 17:33
  4. Ответов: 0
    Последнее сообщение: 31.03.2014, 11:19
  5. Ответов: 10
    Последнее сообщение: 03.02.2012, 18:15

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •