Показано с 1 по 2 из 2
  1. #1
    Юзер
    Регистрация
    31.10.2018
    Сообщений
    1
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Получение данных из РС на текущую дату

    Здравствуйте. Нужна помощь. Получить из РС основная таблица, данные на текущую дату(начало дня) . Затем сравнить , если на текущую дату(начало дня) есть Автомомбиль то тогда подставить значения водитель,грузчик1,2 , если же нет сообщить .

    НаСервере
    Процедура АвтомобильПриИзмененииНаС ервере() // Получаем из РС На Текущую Дату закрепление машины,водителя, грузчиков

    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | ФормированиеБригад.Автомо иль,
    | ФормированиеБригад.Водите ь,
    | ФормированиеБригад.Грузчи 1,
    | ФормированиеБригад.Грузчи 2,
    | ФормированиеБригад.Счетчи Спидометра
    |ИЗ
    | РегистрСведений.Формирова иеБригад КАК ФормированиеБригад
    |ГДЕ
    | ФормированиеБригад.Период = &Дата";

    Выборка = Запрос.Выполнить().Выбрать() ;
    Объект.Автомобиль = Справочники.ТранспортныеС едства.ПустаяСсылка();
    Объект.Водитель = Справочники.Водители.Пуста яСсылка();
    Объект.Грузчик1 = Справочники.Грузчики.Пуста яСсылка();
    Объект.Грузчик2 = Справочники.Грузчики.Пуста яСсылка();


    Если Выборка.Следующий() Тогда
    Объект.Автомобиль = Выборка.Автомобиль;
    Объект.Водитель = Выборка.Водитель;
    Объект.Грузчик1 = Выборка.Грузчик1;
    Объект.Грузчик2 = Выборка.Грузчик2;

    КонецЕсли;


    КонецПроцедуры

    &НаКлиенте
    Процедура АвтомобильПриИзменении(Эл мент) // Проверка автомобиля на день на бригаду
    АвтомобильПриИзмененииНаС ервере();
    Если Объект.Автомобиль.Пустая() = Истина Тогда
    Сообщить("На этот день на бригаду не определена Машина");
    Объект.Автомобиль = "";
    КонецЕсли;
    КонецПроцедуры

  2. #2
    Юзер
    Регистрация
    12.04.2010
    Сообщений
    1
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Re: Получение данных из РС на текущую дату

    установи параметр Дата и добавь условие на автомобиль
    "ВЫБРАТЬ
    | ФормированиеБригад.Автомо ль,
    | ФормированиеБригад.Водите ,
    | ФормированиеБригад.Грузчи1 ,
    | ФормированиеБригад.Грузчи2 ,
    | ФормированиеБригад.Счетчи пидометра
    |ИЗ
    | РегистрСведений.Формирова еБригад КАК ФормированиеБригад
    |ГДЕ
    | ФормированиеБригад.Период = &Дата
    | ФормированиеБригад.Автомо ль = &Автомоиль";

    Запрос.УстановитьПараметр( "Дата", Дата);
    Запрос.УстановитьПараметр( "Автомоиль", Объект.Автомобиль);

Похожие темы

  1. Ответов: 0
    Последнее сообщение: 12.03.2018, 17:52
  2. Получение итогов во вложенном запросе
    от Рашид1977 в разделе Конфигурирование, программирование 1С - Предприятие
    Ответов: 4
    Последнее сообщение: 12.12.2017, 15:47
  3. Получение результата покрытия BullseyeCoverage
    от maxfox111 в разделе Железо (hardware)
    Ответов: 0
    Последнее сообщение: 09.09.2014, 21:06
  4. Ответов: 1
    Последнее сообщение: 16.10.2012, 10:46
  5. получение номера дня в году
    от pbot в разделе СОФТ (SOFT)
    Ответов: 0
    Последнее сообщение: 31.05.2008, 09:25

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •