Показано с 1 по 7 из 7
  1. #1
    Юзер
    Регистрация
    30.06.2018
    Сообщений
    5
    Сказал(а) спасибо
    2
    Поблагодарили 0 раз(а) в 0 сообщениях

    Question Помогите решить задачу по 1С

    Всем привет.

    Помогите пожалуйста решить задачку по 1С. Никак не могу написать код, с требуемым результатом.

    Вот задача;
    Введите интерактивно некоторое предложение (слова разделены пробелами). Выведите
    ряд, сформированный из данного предложения, где каждый последующий элемент ряда
    уменьшается на одно слово. Например:
    Программировать очень интересно и занимательно
    Программировать очень интересно и
    Программировать очень интересно
    Программировать очень
    Программировать

    Буду очень благодарен, даже за подсказку.

  2. #2
    Продвинутый юзер
    Регистрация
    18.07.2018
    Сообщений
    47
    Сказал(а) спасибо
    12
    Поблагодарили 61 раз(а) в 23 сообщениях

    По умолчанию Re: Помогите решить задачу по 1С

    Цитата Сообщение от Михаил1ССС Посмотреть сообщение
    Всем привет.

    Помогите пожалуйста решить задачку по 1С. Никак не могу написать код, с требуемым результатом.

    Вот задача;
    Введите интерактивно некоторое предложение (слова разделены пробелами). Выведите
    ряд, сформированный из данного предложения, где каждый последующий элемент ряда
    уменьшается на одно слово. Например:
    Программировать очень интересно и занимательно
    Программировать очень интересно и
    Программировать очень интересно
    Программировать очень
    Программировать

    Буду очень благодарен, даже за подсказку.
    Функция мРазложитьСтрокуВМассивПо дстрок(Знач Стр, Разделитель = ",") Экспорт

    МассивСтрок = Новый Массив();
    Если Разделитель = " " Тогда
    Стр = СокрЛП(Стр);
    Пока 1=1 Цикл
    Поз = Найти(Стр,Разделитель);
    Если Поз=0 Тогда
    МассивСтрок.Добавить(Стр);
    Возврат МассивСтрок;
    КонецЕсли;
    МассивСтрок.Добавить(Лев(С р,Поз-1));
    Стр = СокрЛ(Сред(Стр,Поз));
    КонецЦикла;
    Иначе
    ДлинаРазделителя = СтрДлина(Разделитель);
    Пока 1=1 Цикл
    Поз = Найти(Стр,Разделитель);
    Если Поз=0 Тогда
    МассивСтрок.Добавить(Стр);
    Возврат МассивСтрок;
    КонецЕсли;
    МассивСтрок.Добавить(Лев(С р,Поз-1));
    Стр = Сред(Стр,Поз+ДлинаРазделит ля);
    КонецЦикла;
    КонецЕсли;

    КонецФункции // глРазложить

  3. Пользователь сказал cпасибо:

    Михаил1ССС (28.07.2018)

  4. #3
    Юзер
    Регистрация
    30.06.2018
    Сообщений
    5
    Сказал(а) спасибо
    2
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Re: Помогите решить задачу по 1С

    Цитата Сообщение от Fltr Посмотреть сообщение
    Функция мРазложитьСтрокуВМассивПо дстрок(Знач Стр, Разделитель = ",") Экспорт

    МассивСтрок = Новый Массив();
    Если Разделитель = " " Тогда
    Стр = СокрЛП(Стр);
    Пока 1=1 Цикл
    Поз = Найти(Стр,Разделитель);
    Если Поз=0 Тогда
    МассивСтрок.Добавить(Стр);
    Возврат МассивСтрок;
    КонецЕсли;
    МассивСтрок.Добавить(Лев(С р,Поз-1));
    Стр = СокрЛ(Сред(Стр,Поз));
    КонецЦикла;
    Иначе
    ДлинаРазделителя = СтрДлина(Разделитель);
    Пока 1=1 Цикл
    Поз = Найти(Стр,Разделитель);
    Если Поз=0 Тогда
    МассивСтрок.Добавить(Стр);
    Возврат МассивСтрок;
    КонецЕсли;
    МассивСтрок.Добавить(Лев(С р,Поз-1));
    Стр = Сред(Стр,Поз+ДлинаРазделит ля);
    КонецЦикла;
    КонецЕсли;

    КонецФункции // глРазложить
    Спасибо

  5. #4
    Юзер
    Регистрация
    30.06.2018
    Сообщений
    5
    Сказал(а) спасибо
    2
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Re: Помогите решить задачу по 1С

    Цитата Сообщение от Fltr Посмотреть сообщение
    Функция мРазложитьСтрокуВМассивПо дстрок(Знач Стр, Разделитель = ",") Экспорт

    МассивСтрок = Новый Массив();
    Если Разделитель = " " Тогда
    Стр = СокрЛП(Стр);
    Пока 1=1 Цикл
    Поз = Найти(Стр,Разделитель);
    Если Поз=0 Тогда
    МассивСтрок.Добавить(Стр);
    Возврат МассивСтрок;
    КонецЕсли;
    МассивСтрок.Добавить(Лев(С р,Поз-1));
    Стр = СокрЛ(Сред(Стр,Поз));
    КонецЦикла;
    Иначе
    ДлинаРазделителя = СтрДлина(Разделитель);
    Пока 1=1 Цикл
    Поз = Найти(Стр,Разделитель);
    Если Поз=0 Тогда
    МассивСтрок.Добавить(Стр);
    Возврат МассивСтрок;
    КонецЕсли;
    МассивСтрок.Добавить(Лев(С р,Поз-1));
    Стр = Сред(Стр,Поз+ДлинаРазделит ля);
    КонецЦикла;
    КонецЕсли;

    КонецФункции // глРазложить
    Спасибо

  6. #5
    Юзер
    Регистрация
    30.06.2018
    Сообщений
    5
    Сказал(а) спасибо
    2
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Re: Помогите решить задачу по 1С

    Я не смог решить еще одну задачу....

    Выведите 12 месяцев, используя цикл Для..Цикл, и функцию Формат

    Поможете?))

  7. #6
    Продвинутый юзер
    Регистрация
    18.07.2018
    Сообщений
    47
    Сказал(а) спасибо
    12
    Поблагодарили 61 раз(а) в 23 сообщениях

    По умолчанию Re: Помогите решить задачу по 1С

    Цитата Сообщение от Михаил1ССС Посмотреть сообщение
    Я не смог решить еще одну задачу....

    Выведите 12 месяцев, используя цикл Для..Цикл, и функцию Формат

    Поможете?))
    Для к=1 по 12 цикл
    Сообщить(Формат(Дата(2009, к, 1), "ДФ=ММММ"));
    КонецЦикла;

  8. Пользователь сказал cпасибо:

    Михаил1ССС (28.07.2018)

  9. #7
    Юзер
    Регистрация
    30.06.2018
    Сообщений
    5
    Сказал(а) спасибо
    2
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Re: Помогите решить задачу по 1С

    Цитата Сообщение от Fltr Посмотреть сообщение
    Для к=1 по 12 цикл
    Сообщить(Формат(Дата(2009, к, 1), "ДФ=ММММ"));
    КонецЦикла;
    Спасибо. Получилось
    [Только зарегистрированные пользователи могут видеть ссылки. ]



Похожие темы

  1. Помогите решить задачу
    от Mbutch в разделе Установка и администрирование 1С - Предприятие
    Ответов: 10
    Последнее сообщение: 30.01.2017, 13:30
  2. Помогите решить проблему
    от nastepka93 в разделе Общие вопросы по 1С - Предприятие
    Ответов: 2
    Последнее сообщение: 16.01.2016, 23:43
  3. помогите решить задание
    от lala55 в разделе Общие вопросы по 1С - Предприятие
    Ответов: 0
    Последнее сообщение: 12.11.2013, 14:39
  4. помогите решить
    от darkladydreams в разделе Прикладное программирование
    Ответов: 8
    Последнее сообщение: 07.10.2010, 20:51
  5. Помогите решить проблему
    от kidm в разделе Полезные ссылки для скачивания
    Ответов: 4
    Последнее сообщение: 16.02.2010, 22:34

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •