Показано с 1 по 2 из 2
  1. #1
    Юзер
    Регистрация
    13.07.2016
    Сообщений
    3
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Округление суммы

    Есть проблема. в 1с 8.3 УТ1.1 необходимо сделать округление итоговой суммы со скидкой. Само округление я сделал, но оно работает только с проведенным документом. не могу понять где нужно поправить в конфигураторе чтобы при оформлении заказа покупателя со скидкой работало округление до целого числа (т.е. без копеек). вот то что я сделал
    Процедура РассчитатьСуммуТабЧасти(С рокаТабличнойЧасти, ДокументОбъект, СпособРасчета = Неопределено) Экспорт

    ИмяТабличнойЧасти = ОбщегоНазначения.Получить мяТабличнойЧастиПоСсылке аСтроку(СтрокаТабличнойЧа сти);

    МетаданныеДокумента = ДокументОбъект.Метаданные( );

    Сумма = СтрокаТабличнойЧасти.Цена * СтрокаТабличнойЧасти.Коли ество;
    СуммаСкидки = 0;

    Если (СпособРасчета = Неопределено)
    Или (СпособРасчета = Перечисления.СпособРасчет СуммыДокумента.СУчетомВсе хСкидок)
    Или (СпособРасчета = Перечисления.СпособРасчет СуммыДокумента.БезУчетаРу чнойСкидки) Тогда
    Если ОбщегоНазначения.ЕстьРекв зитТабЧастиДокумента("Про ентАвтоматическихСкидок", МетаданныеДокумента, ИмяТабличнойЧасти) Тогда
    СуммаСкидки = Сумма * СтрокаТабличнойЧасти.Проц нтАвтоматическихСкидок / 100;
    КонецЕсли;

    Если (СпособРасчета <> Перечисления.СпособРасчет СуммыДокумента.БезУчетаРу чнойСкидки)Тогда
    Если ОбщегоНазначения.ЕстьРекв зитТабЧастиДокумента("Про ентСкидкиНаценки", МетаданныеДокумента, ИмяТабличнойЧасти) Тогда
    СуммаСкидки = СуммаСкидки + (Сумма * СтрокаТабличнойЧасти.Проц нтСкидкиНаценки / 100);
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;

    СтрокаТабличнойЧасти.Сумм = Сумма - СуммаСкидки;
    СтрокаТабличнойЧасти.Сумм = Окр(СтрокаТабличнойЧасти.С умма, 0);
    КонецПроцедуры // РассчитатьСуммуТабЧасти()

  2. #2
    Завсегдатай форума
    Регистрация
    28.01.2012
    Сообщений
    901
    Сказал(а) спасибо
    16
    Поблагодарили 866 раз(а) в 328 сообщениях

    По умолчанию Re: Округление суммы

    Цитата Сообщение от Ilichg Посмотреть сообщение
    Есть проблема. в 1с 8.3 УТ1.1 необходимо сделать округление итоговой суммы со скидкой. Само округление я сделал, но оно работает только с проведенным документом. не могу понять где нужно поправить в конфигураторе чтобы при оформлении заказа покупателя со скидкой работало округление до целого числа (т.е. без копеек). вот то что я сделал
    Процедура РассчитатьСуммуТабЧасти(С рокаТабличнойЧасти, ДокументОбъект, СпособРасчета = Неопределено) Экспорт

    ИмяТабличнойЧасти = ОбщегоНазначения.Получить мяТабличнойЧастиПоСсылке аСтроку(СтрокаТабличнойЧа сти);

    МетаданныеДокумента = ДокументОбъект.Метаданные( );

    Сумма = СтрокаТабличнойЧасти.Цена * СтрокаТабличнойЧасти.Коли ество;
    СуммаСкидки = 0;

    Если (СпособРасчета = Неопределено)
    Или (СпособРасчета = Перечисления.СпособРасчет СуммыДокумента.СУчетомВсе хСкидок)
    Или (СпособРасчета = Перечисления.СпособРасчет СуммыДокумента.БезУчетаРу чнойСкидки) Тогда
    Если ОбщегоНазначения.ЕстьРекв зитТабЧастиДокумента("Про ентАвтоматическихСкидок", МетаданныеДокумента, ИмяТабличнойЧасти) Тогда
    СуммаСкидки = Сумма * СтрокаТабличнойЧасти.Проц нтАвтоматическихСкидок / 100;
    КонецЕсли;

    Если (СпособРасчета <> Перечисления.СпособРасчет СуммыДокумента.БезУчетаРу чнойСкидки)Тогда
    Если ОбщегоНазначения.ЕстьРекв зитТабЧастиДокумента("Про ентСкидкиНаценки", МетаданныеДокумента, ИмяТабличнойЧасти) Тогда
    СуммаСкидки = СуммаСкидки + (Сумма * СтрокаТабличнойЧасти.Проц нтСкидкиНаценки / 100);
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;

    СтрокаТабличнойЧасти.Сумм = Сумма - СуммаСкидки;
    СтрокаТабличнойЧасти.Сумм = Окр(СтрокаТабличнойЧасти.С умма, 0);
    КонецПроцедуры // РассчитатьСуммуТабЧасти()

    Лучше пишите тут [Только зарегистрированные пользователи могут видеть ссылки. ] там народу больше и все программисты 1с
    Если помог, нажми "Спасибо"

Похожие темы

  1. лишние суммы
    от Изумрудна в разделе Конфигурирование, программирование 1С - Предприятие
    Ответов: 1
    Последнее сообщение: 12.06.2015, 09:11
  2. Округление цен в 1с
    от Natascha1990 в разделе Конфигурирование, программирование 1С - Предприятие
    Ответов: 1
    Последнее сообщение: 07.02.2013, 18:47
  3. Амортизация имущества, изменение суммы
    от Сергей_Туапсе в разделе 1С Предприятие 7.7
    Ответов: 0
    Последнее сообщение: 14.03.2011, 10:58
  4. Округление до 4х знаков после запятой
    от Наг в разделе 1С Предприятие 7.7
    Ответов: 7
    Последнее сообщение: 25.05.2010, 15:19

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •