Страница 2 из 2 ПерваяПервая 12
Показано с 11 по 20 из 20
  1. #11
    Юзер
    Регистрация
    24.02.2011
    Сообщений
    7
    Сказал(а) спасибо
    11
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию

    Ремовать инициализацию защиты не проблема. Как подменить компилированный ИМП_Непоставляемый.

  2. #12
    Юзер
    Регистрация
    24.10.2011
    Сообщений
    6
    Сказал(а) спасибо
    2
    Поблагодарили 7 раз(а) в 1 сообщении

    По умолчанию

    а как это сделать?

  3. #13
    Юзер
    Регистрация
    24.02.2011
    Сообщений
    7
    Сказал(а) спасибо
    11
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию

    Знал бы...
    Не спрашивал бы...

  4. #14
    Юзер
    Регистрация
    29.07.2009
    Сообщений
    9
    Сказал(а) спасибо
    3
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию

    Попрежнему актуально.
    Никто задачу не решил?

  5. #15
    Юзер
    Регистрация
    05.06.2008
    Сообщений
    17
    Сказал(а) спасибо
    1
    Поблагодарили 9 раз(а) в 5 сообщениях

    По умолчанию

    я решил , компилированный ИМП_Непоставляемый нужно сначала декомпелировать и закоментировать там нужные строки

  6. #16
    Юзер
    Регистрация
    10.03.2014
    Адрес
    Кыргыз
    Сообщений
    9
    Сказал(а) спасибо
    6
    Поблагодарили 1 раз в 1 сообщении

    По умолчанию

    Цитата Сообщение от koloboc74 Посмотреть сообщение
    я решил , компилированный ИМП_Непоставляемый нужно сначала декомпелировать и закоментировать там нужные строки
    может подскажитеИ?

    Функция ИНАГРО_ИнициализироватьЗа итуКонфигурации() Экспорт

    ПараметрыСеанса.ИНАГРО_Сис темаЗащитыИнициализирован а = Истина;//Ложь;
    КомпонентаПодключена = Истина;
    глБСПУ = Истина;
    глБЭМКЗ = Истина;
    глБСПУ_БЭМКЗ = Истина;

    Если ИНАГРО_ПодключитьКомпонен уСЛК() Тогда //НЕ
    КомпонентаПодключена = Истина;//Ложь;
    КонецЕсли;

    Если КомпонентаПодключена Тогда //Эрулан
    Попытка
    МенеджерЛицензий = Новый("AddIn.Licence.LicenceExtension20");
    Исключение
    Сообщить(ОписаниеОшибки());
    КомпонентаПодключена = Ложь;
    КонецПопытки;
    КонецЕсли;

    Если КомпонентаПодключена Тогда
    КомпонентаПодключена = МенеджерЛицензий.Запуск(ИН АГРО_ОбщийПовторногоИспол зования.Серия());
    глБСПУ = КомпонентаПодключена;
    КонецЕсли;

    Если КомпонентаПодключена Тогда
    #Если Клиент Тогда
    Псевдоним = ИНАГРО_ОбщийПовторногоИсп льзования.ИНАГРО_Получить севдоним();
    ВерсияФайлов = МенеджерЛицензий.Получить начениеПараметра(Псевдони м + "Релиз");
    ВерсияКонфигурации = Метаданные.Версия;
    Если ВерсияФайлов <> ВерсияКонфигурации Тогда
    ТекстВопроса = " ВНИМАНИЕ!
    |Файлы защиты не соответствуют версии конфигурации.
    |Файлы защиты предназаначены для версии конфигурации " + ВерсияФайлов + "
    |Корректная работа конфигурации с указанными файлами защиты не гарантируется.";
    Предупреждение(ТекстВопро а, 120);
    КонецЕсли;
    #КонецЕсли

    ПараметрыСеанса.ИНАГРО_Сис темаЗащитыИнициализирован а = Истина;
    Возврат Истина;
    КонецЕсли;

    #Если Клиент Тогда
    Если Метаданные.Имя = "БухгалтерияСельскохозяйс венногоПредприятия" Тогда
    ИмяМет = "ИН-АГРО: Бухгалтерия сельскохозяйственного предприятия для Украины";
    ИначеЕсли Метаданные.Имя = "БухгалтерияЭлеватораМель ицыИКомбикормовогоЗавода ляУкраины" Тогда
    ИмяМет = "ИН-АГРО: Бухгалтерия элеватора, мельницы и комбикормового завода для Украины";
    Иначе
    ИмяМет = "ИН-АГРО: Комплексное решение сельскохозяйственного предприятия для Украины";
    КонецЕсли;
    ТекстВопроса = " ВНИМАНИЕ!
    |Не удалось инициализировать систему аппаратной защиты
    |для конфигурации " + ИмяМет +".
    |Подсистема не будет работать корректно без файлов защиты";
    Предупреждение(ТекстВопро а, 120);
    #КонецЕсли

    Возврат Ложь;

    КонецФункции // ИнициализироватьЗащитуКон фигурации()

    ---------- Post added at 22:06 ---------- Previous post was at 21:24 ----------

    Цитата Сообщение от koloboc74 Посмотреть сообщение
    я решил , компилированный ИМП_Непоставляемый нужно сначала декомпелировать и закоментировать там нужные строки
    может подскажитеИ?

    Функция ИНАГРО_ИнициализироватьЗа итуКонфигурации() Экспорт

    ПараметрыСеанса.ИНАГРО_Сис темаЗащитыИнициализирован а = Истина;//Ложь;
    КомпонентаПодключена = Истина;
    глБСПУ = Истина;
    глБЭМКЗ = Истина;
    глБСПУ_БЭМКЗ = Истина;

    Если ИНАГРО_ПодключитьКомпонен уСЛК() Тогда //НЕ
    КомпонентаПодключена = Истина;//Ложь;
    КонецЕсли;

    Если КомпонентаПодключена Тогда //
    Попытка
    МенеджерЛицензий = Новый("AddIn.Licence.LicenceExtension20");
    Исключение
    Сообщить(ОписаниеОшибки());
    КомпонентаПодключена = Ложь;
    КонецПопытки;
    КонецЕсли;

    Если КомпонентаПодключена Тогда
    КомпонентаПодключена = МенеджерЛицензий.Запуск(ИН АГРО_ОбщийПовторногоИспол зования.Серия());
    глБСПУ = КомпонентаПодключена;
    КонецЕсли;

    Если КомпонентаПодключена Тогда
    #Если Клиент Тогда
    Псевдоним = ИНАГРО_ОбщийПовторногоИсп льзования.ИНАГРО_Получить севдоним();
    ВерсияФайлов = МенеджерЛицензий.Получить начениеПараметра(Псевдони м + "Релиз");
    ВерсияКонфигурации = Метаданные.Версия;
    Если ВерсияФайлов <> ВерсияКонфигурации Тогда
    ТекстВопроса = " ВНИМАНИЕ!
    |Файлы защиты не соответствуют версии конфигурации.
    |Файлы защиты предназаначены для версии конфигурации " + ВерсияФайлов + "
    |Корректная работа конфигурации с указанными файлами защиты не гарантируется.";
    Предупреждение(ТекстВопро а, 120);
    КонецЕсли;
    #КонецЕсли

    ПараметрыСеанса.ИНАГРО_Сис темаЗащитыИнициализирован а = Истина;
    Возврат Истина;
    КонецЕсли;

    #Если Клиент Тогда
    Если Метаданные.Имя = "БухгалтерияСельскохозяйс венногоПредприятия" Тогда
    ИмяМет = "ИН-АГРО: Бухгалтерия сельскохозяйственного предприятия для Украины";
    ИначеЕсли Метаданные.Имя = "БухгалтерияЭлеватораМель ицыИКомбикормовогоЗавода ляУкраины" Тогда
    ИмяМет = "ИН-АГРО: Бухгалтерия элеватора, мельницы и комбикормового завода для Украины";
    Иначе
    ИмяМет = "ИН-АГРО: Комплексное решение сельскохозяйственного предприятия для Украины";
    КонецЕсли;
    ТекстВопроса = " ВНИМАНИЕ!
    |Не удалось инициализировать систему аппаратной защиты
    |для конфигурации " + ИмяМет +".
    |Подсистема не будет работать корректно без файлов защиты";
    Предупреждение(ТекстВопро а, 120);
    #КонецЕсли

    Возврат Ложь;

    КонецФункции // ИнициализироватьЗащитуКон фигурации()

  7. #17
    Юзер
    Регистрация
    02.02.2015
    Сообщений
    1
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию

    Вот пожалуйста [Только зарегистрированные пользователи могут видеть ссылки. ] думаю что помог вам в вашем решение!))

  8. #18
    Юзер
    Регистрация
    10.02.2011
    Сообщений
    1
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Re: Как установить ключ защиты для конф."Бухгалтерия строительной организации"?

    Вот так работает, и не требует ключа

    Процедура ПриНачалеРаботыСистемы()


    ОсвобождатьЛицензиюПриЗав ершенииРаботы = ИмпНепоставляемый.Освобож атьЛицензиюПриЗавершении аботы();

    //Попытка
    // ИмпНепоставляемый.Запуск();
    //Исключение

    // ПараметрыСвязи = "";
    // Если Не ИмпНепоставляемый.ЗапускМ неджераЛицензий(Параметры Связи) Тогда
    // ПараметрыОткрытия = Новый Структура("ЗавершатьРаботу Системы, ПараметрыСвязи", Истина, ПараметрыСвязи);
    // ОткрытьФорму("ОбщаяФорма.И пФормаНастройкиЗащитыСЛК" , ПараметрыОткрытия,,,Вариан ОткрытияОкна.ОтдельноеОкн о,,,РежимОткрытияОкнаФормы. БлокироватьВесьИнтерфейс);
    // КонецЕсли;

    //КонецПопытки;

    // СтандартныеПодсистемы
    СтандартныеПодсистемыКлие нт.ПриНачалеРаботыСистемы( );
    // Конец СтандартныеПодсистемы

    //РаботаСВнешнимОборудовани ем
    МенеджерОборудованияКлиен т.ПриНачалеРаботыСистемы();
    //Конец РаботаСВнешнимОборудовани ем

    КонецПроцедуры

  9. #19
    Юзер
    Регистрация
    22.11.2018
    Сообщений
    7
    Сказал(а) спасибо
    2
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию Re: Как установить ключ защиты для конф."Бухгалтерия строительной организации"?

    Добрый день У нашей организации есть 45 лицензии. У нас какимта образом работают сиволиш примерно 20 лицензии у нас подключено без ключа Usb флешки ественно когда входишь в 1с он ругается что нету свободных лицензии хотя 2 дня назад все работала можете помочь как мне

  10. #20
    Юзер
    Регистрация
    12.04.2008
    Сообщений
    10
    Сказал(а) спасибо
    4
    Поблагодарили 5 раз(а) в 2 сообщениях

    По умолчанию Re: Как установить ключ защиты для конф."Бухгалтерия строительной организации"?

    Расширение конфигурации позволяющее работать с конфигурацией 3.1.66.*
    [Только зарегистрированные пользователи могут видеть ссылки. ] пароль ru-board

Страница 2 из 2 ПерваяПервая 12

Похожие темы

  1. 1С Предприятие 8.1. "Управление строительной организацией"
    от vesjoloe21 в разделе Полезные ссылки для скачивания
    Ответов: 8
    Последнее сообщение: 08.02.2014, 03:59
  2. Ответов: 1
    Последнее сообщение: 06.08.2010, 21:43
  3. Ответов: 4
    Последнее сообщение: 13.06.2010, 00:45
  4. Обновление конфигурации "Бухгалтерия Предприятия" 8.2.10
    от vasuchina в разделе Полезные ссылки для скачивания
    Ответов: 2
    Последнее сообщение: 13.04.2010, 16:38
  5. Хитрая работа конфигурации 1С:Управление строительной организацией
    от alkasatka в разделе Полезные ссылки для скачивания
    Ответов: 5
    Последнее сообщение: 01.01.2010, 18:25

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •