Показано с 1 по 9 из 9
  1. #1
    Гость форума Аватар для duh.seti
    Регистрация
    15.01.2010
    Сообщений
    4
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию в форме 0503168 отсутствует кнопка "Заполнить" 1С 7.7 бюджет

    Приветствую, знатоки, кто нибудь сталкивался с таким:
    1С 7.7 бюджет релиз 635, платформа 27
    отчетность за 4 квартал 2009 года
    в формах 0503168 и 0503110 отсутствует кнопка "Заполнить" (причем следующая за ней кнопка "Расширить" есть)
    чем лечить?

  2. #2
    Заблокирован
    Регистрация
    28.12.2009
    Сообщений
    191
    Сказал(а) спасибо
    0
    Поблагодарили 30 раз(а) в 20 сообщениях

    По умолчанию

    Цитата Сообщение от duh.seti Посмотреть сообщение
    Приветствую, знатоки, кто нибудь сталкивался с таким:
    1С 7.7 бюджет релиз 635, платформа 27
    отчетность за 4 квартал 2009 года
    в формах 0503168 и 0503110 отсутствует кнопка "Заполнить" (причем следующая за ней кнопка "Расширить" есть)
    чем лечить?
    Бюджетка типовая?

  3. #3
    Гость форума Аватар для duh.seti
    Регистрация
    15.01.2010
    Сообщений
    4
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию

    Цитата Сообщение от SJ24 Посмотреть сообщение
    Бюджетка типовая?
    да типовая

  4. #4
    Заблокирован
    Регистрация
    28.12.2009
    Сообщений
    191
    Сказал(а) спасибо
    0
    Поблагодарили 30 раз(а) в 20 сообщениях

    По умолчанию

    Цитата Сообщение от duh.seti Посмотреть сообщение
    да типовая
    Странно, похоже просто какой-то глюк. опробуй открыть формы в конфигураторе и закомментировать строки, отвечающие за видимость кнопки.

  5. #5
    Гость форума Аватар для duh.seti
    Регистрация
    15.01.2010
    Сообщений
    4
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию

    не думаю что проблема в формах... (у других бухгалтеров эта же форма проблем с кнопками не имеет) релиз, платформа, отчетность у всех одинаковые (сам ставил) вот думаю может настройка где нить или чтонибудь по бух учету... (я не бухгалтер... сисадмин я)

  6. #6
    Заблокирован
    Регистрация
    28.12.2009
    Сообщений
    191
    Сказал(а) спасибо
    0
    Поблагодарили 30 раз(а) в 20 сообщениях

    По умолчанию

    Цитата Сообщение от duh.seti Посмотреть сообщение
    не думаю что проблема в формах... (у других бухгалтеров эта же форма проблем с кнопками не имеет) релиз, платформа, отчетность у всех одинаковые (сам ставил) вот думаю может настройка где нить или чтонибудь по бух учету... (я не бухгалтер... сисадмин я)
    Настроек точно никаких нет, могу сказать на 100 %

  7. #7
    Гость форума
    Регистрация
    31.12.2009
    Сообщений
    2
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию

    В форме 110 осуществляется проверка на соответствие состава метаданных необходимому минимуму для автозаполнения, при не соответствии - заполняй ручками

  8. #8
    Гость форума Аватар для duh.seti
    Регистрация
    15.01.2010
    Сообщений
    4
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию

    Цитата Сообщение от 7onoff Посмотреть сообщение
    В форме 110 осуществляется проверка на соответствие состава метаданных необходимому минимуму для автозаполнения, при не соответствии - заполняй ручками
    тоесть каких то документов не хватает? или поля не заполненные... я правильно понял?

  9. #9
    Гость форума
    Регистрация
    31.12.2009
    Сообщений
    2
    Сказал(а) спасибо
    0
    Поблагодарили 0 раз(а) в 0 сообщениях

    По умолчанию

    Процедура ОпределениеТипаКонфигурац ии()

    Если (Метаданные.Справочник("Фир мы").Выбран() = 1) Тогда
    Форма.ВыбраннаяФирма.Назна читьТип("Справочник.Фирмы");
    Форма.ВыбраннаяФирма.Видим ость(1);
    Форма.РамкаУчреждение.Види мость(1);
    ТипКонфигурации = "1";
    Иначе
    ТипКонфигурации = "0";
    КонецЕсли;

    Если (Метаданные.Справочник("ФКР ").Выбран() = 1) Тогда
    СпрКБК = СоздатьОбъект("Справочник. КР");
    ТипКонфигурации = ТипКонфигурации + "1";
    ИначеЕсли (Метаданные.Справочник("КБК ").Выбран() = 1) Тогда
    СпрКБК = СоздатьОбъект("Справочник. БК");
    ТипКонфигурации = ТипКонфигурации + "1";
    Иначе
    ТипКонфигурации = ТипКонфигурации + "0";
    КонецЕсли;

    БюджетныйПланСчетов = "0";
    Если (Метаданные.ПланСчетов() > 0) Тогда
    Если (ПустаяСтрока(ПланыСчетов. начениеПоИдентификатору(" ПСБУ")) = 0) Тогда
    БюджетныйПланСчетов = "1";
    ИначеЕсли (ПустаяСтрока(ПланыСчетов. начениеПоИдентификатору(" юджетныйУчет")) = 0) Тогда
    БюджетныйПланСчетов = "2";
    КонецЕсли;
    Если (БюджетныйПланСчетов <> "0") Тогда
    Если (Метаданные.РеквизитСчета(1 ).Выбран() = 0) Тогда
    БюджетныйПланСчетов = "0";
    ИначеЕсли (Метаданные.РеквизитСчета(1 ).Идентификатор <>"ИсточникФинансирования" ) Тогда
    БюджетныйПланСчетов = "0";
    ИначеЕсли (Метаданные.РеквизитСчета(1 ).Тип <> "Перечисление") Тогда
    БюджетныйПланСчетов = "0";
    ИначеЕсли (Метаданные.РеквизитСчета(1 ).Вид <> "КодВидаДеятельности") Тогда
    БюджетныйПланСчетов = "0";
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    Если (БюджетныйПланСчетов = "1") Тогда
    СпрБСЧ = СоздатьОбъект("Счет.ЕПСБУ");
    ИначеЕсли (БюджетныйПланСчетов = "2") Тогда
    СпрБСЧ = СоздатьОбъект("Счет.Бюджет ыйУчет");
    Иначе
    БюджетныйПланСчетов = "0";
    КонецЕсли;
    ТипКонфигурации = ТипКонфигурации + БюджетныйПланСчетов;

    Если (Метаданные.Справочник("Наб орыРеквизитовФорм").Выбран( ) = 1) Тогда
    ТипКонфигурации = ТипКонфигурации + "1";
    Иначе
    ТипКонфигурации = ТипКонфигурации + "0";
    КонецЕсли;

    Если (Метаданные.Справочник("ППП ").Выбран() = 1) Тогда
    ТипКонфигурации = ТипКонфигурации + "1";
    СпрППП = СоздатьОбъект("Справочник. ПП");
    Иначе
    ТипКонфигурации = ТипКонфигурации + "0";
    КонецЕсли;

    Если (Метаданные.Справочник("Раз делы").Выбран() = 1) Тогда
    ТипКонфигурации = ТипКонфигурации + "1";
    СпрРЗПР = СоздатьОбъект("Справочник. азделы");
    Иначе
    ТипКонфигурации = ТипКонфигурации + "0";
    КонецЕсли;

    Если (Метаданные.Справочник("Кла ссификацияДоходов").Выбран( ) = 1) Тогда
    ТипКонфигурации = ТипКонфигурации + "1";
    СпрКДБ = СоздатьОбъект("Справочник. лассификацияДоходов");
    Иначе
    ТипКонфигурации = ТипКонфигурации + "0";
    КонецЕсли;

    Если (Метаданные.Справочник("ОГС ").Выбран() = 1) Тогда
    ТипКонфигурации = ТипКонфигурации + "1";
    СпрКОСГУ = СоздатьОбъект("Справочник. ГС");
    ИначеЕсли (Метаданные.Справочник("ЭКР асходов").Выбран() = 1) Тогда
    ТипКонфигурации = ТипКонфигурации + "1";
    СпрКОСГУ = СоздатьОбъект("Справочник. КРасходов");
    Иначе
    ТипКонфигурации = ТипКонфигурации + "0";
    КонецЕсли;

    Если (Метаданные.Справочник("Пла нСчетов").Выбран() = 1) Тогда //свод
    ТипКонфигурации = ТипКонфигурации + "1";
    СпрБСЧ = СоздатьОбъект("Справочник. ланСчетов");
    Иначе
    ТипКонфигурации = ТипКонфигурации + "0";
    КонецЕсли;

    Если (Метаданные.Справочник("Вал юты").Выбран() = 1) Тогда
    ТипКонфигурации = ТипКонфигурации + "1";
    СпрВАЛ = СоздатьОбъект("Справочник. алюты");
    Иначе
    ТипКонфигурации = ТипКонфигурации + "0";
    КонецЕсли;

    Если Метаданные.Справочник("Цел выеСтатьи").Выбран()=1 Тогда
    //ТипКонфигурации=ТипКонфиг рации+"1";
    СпрЦСР=СоздатьОбъект("Спра очник.ЦелевыеСтатьи");
    Иначе
    ТипКонфигурации=ТипКонфиг рации+"0";
    КонецЕсли;

    Если (ТипКонфигурации = "1110111101")
    Или (ТипКонфигурации = "1120111101") Тогда
    Форма.КнЗаполнить.Видимост ь(1);
    Форма.ФлКОСГУ.Видимость(1);
    Форма.ПоВсем.Видимость(1);
    Форма.Раскрыть.Видимость(0);
    СпП.НоваяКолонка("НомСтрок ");
    СпП.НоваяКолонка("ИмяЯчейк ");
    СпП.НоваяКолонка("ИмяПоказ теля");
    СпП.НоваяКолонка("ИмяСлага мого");
    СпП.НоваяКолонка("ЗнакОпер ции");
    СпП.НоваяКолонка("Сумма");
    СпП.НоваяКолонка("КодСчета" );
    СпП.НоваяКолонка("КодКорСч та");
    СпП.НоваяКолонка("Коммента ий");
    СпП.НоваяКолонка("ВидСубко то1");
    СпП.НоваяКолонка("Субконто1 ");
    Иначе
    Форма.КнЗаполнить.Видимост ь(0);
    Форма.ФлКОСГУ.Видимость(0);
    Форма.ПоВсем.Видимость(0);
    Форма.Раскрыть.Видимость(0);
    КонецЕсли;

    КонецПроцедуры // ОпределениеТипаКонфигурац ии()

Похожие темы

  1. Отчет о матче ФК "Москва" - "Терек".
    от EweX в разделе Футбол
    Ответов: 1
    Последнее сообщение: 26.09.2020, 20:38
  2. Ответов: 1
    Последнее сообщение: 25.11.2013, 13:14
  3. Ищу программу ИСА "1С:Консалтинг.Стандарт"
    от AlexRTW в разделе Полезные ссылки для скачивания
    Ответов: 3
    Последнее сообщение: 11.09.2009, 12:05
  4. Ответов: 0
    Последнее сообщение: 14.07.2008, 10:55
  5. Ответов: 0
    Последнее сообщение: 14.07.2008, 10:53

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •